Dsp-js sources, versions, naming, error handling

so that’s exactly it:

when you workout the IRI, if the host is not localhost or 0.0.0.0, then you should not include the port.

does it work for you now?

Sorry Tobias, I don’t know if it works, I only looked up knora code.

I am implementing it now in knora-api-js-lib, then I’ll test and let you know.

I’ll be right back :slight_smile:

1 Like

here it is: https://github.com/dasch-swiss/knora-api-js-lib/pull/196

I tested and it works for me with that change.

(it took more time to try -and fail!- to configure the editor’s formatter to not change the whole file when saving)

editing test file now

@loic.jaouen A new release of JS-lib is available: https://www.npmjs.com/package/@dasch-swiss/dsp-js/v/1.0.0-rc.2 It contains the fixes (see https://github.com/dasch-swiss/knora-api-js-lib/releases/tag/v1.0.0-rc.2).

Note that it’s called @dasch-swiss/dsp-js now (instead of @knora/api)

@t.schweizer cool, thanks for the notification. I have already the new name as right now I import a local version from a local registry. I will be happy to switch back to an official version :slight_smile:

1 Like

@loic.jaouen Do you have access to the DSP version matrix?

DSP version matrix

what is it?

https://docs.google.com/spreadsheets/d/1UWDFQ-2FYJw6SsKl2zznBldTPcl7Vvn3Z9ZbJfFz-UA/edit?pli=1#gid=0

If you cannot view it, please ask @subotic to give you access

1 Like